Copy of RE2 for N64 cannot save at all even with new battery


New Member
May 18, 2023
Nintendo 64
I came across a copy of Resident Evil for the Ninteno 64 that wasn't saving. But I noticed something odd. The game wasn't saving AT ALL, even while it still had power. You can save, then try to save again and see nothing is there. I've replaced a bunch of batteries in other N64 and GB games and usually it works fine after that. But this game stayed the same.

I tried 2 different batteries just in case I had a dud. No luck. New battery still doesn't save at all. Soldier joints are good, no apparent damage or corrosion anywhere on the board. I double checked to make sure the battery was oriented properly, because the positive terminal faces south in RE2 as opposed to north in Ocarina. Everything was fine in that regard.

Any of you encountered this before?
Which game are you talking about? There was no Resident Evil 4 for N64.
Ah! My love of Resident Evil 4 froidian slipped me. I was talking about Resident Evil 2. I just fixed the title
Could it be one of those Chinese "reproduction" carts? They have a problem with SRAM saving. You can tell by looking at the board.
As far as I can tell its genuine. 1, the insides match perfectly to images online of genuine carts; and 2, the cart is totally beat to crap jajaja.

It sounds like it just got damaged. I don't know enough about circuits to understand where the damage is; but the way that the save state is deleted even if the game doesnt lose power; this suggests that there may be some damage. Usually if the save battery is the problem, then you can save the game and look at the save file. But then when you turn off the power; the save file will disappear.

In this case; there is absolutely no saving. You can save the game, go to save again; and there are no save files. Maybe that's normal for RE2, though. Not sure.

Latest posts

Latest threads