Wii U Internet Won't Work

Bowser05

New Member
Karma
0
Playing
Wii U
Hi! I hope everybody is doing well! I'm having some unique issues with my Wii U that I haven't been able to solve, after months of searching and trying things. This post is going to be a bit lengthy, but it's because I want you guys to know every details of what I've tried, in the hopes that you can provide some new information that might get the job done.

The Problem: My Wii U won't connect to the internet via Wi-Fi OR Wired. The odd thing is that after fiddling with some router settings, I can get it to connect well enough to do system updates, but I can never connect to the eShop, and I can't play any games online. It usually reverts to saying 'can't find network' when I do a network test, but for a little bit it'll say it connects right and will let me only do updates. I've tried Mario Kart, Wii Sports and Smash so far, all saying they can't connect to the internet (as well as the eShop of course).

The Concern: I suspect the network card is shot, as it's a launch console and one of the USB ports is dead too, but that doesn't explain why when I plug in a network adapter, it isn't even detected (more on that in a bit). I wouldn't mind just buying a whole different console, but I have over $3000 of digital purchases and from what I'm aware, Nintendo will NOT allow you to transfer that (not to mention I have a bunch of Wii Shop purchases which I won't be able to get back again). So I'm stuck at an impasse, as there's some last few Virtual Console games and DLC I'd like to buy and download before the Wii U support finally is gone.

The Equipment: So here's what my setup looks like. I have the Black 32GB launch Wii U console. (When facing the back of the console) The top right USB port is dead. I have a 250GB SSD in an externally powered enclosure plugged into the other functioning USB port. I also have a 32GB SD card in the console for my Wii purchases. I have about 70 digital games installed on my external and maybe 7 on my SD card. Nothing installed internally beyond the basics like the internet channel and some dead stuff like Netflix and that Google Earth-like app. I'm using a Netgear Nighthawk R7000P (firmware 1.3.1.64) with WPA2-PSK security. Keep in mind everything else I own works fine, including my 3DS, PSVita and Switch.

Attempted Solutions: Alright, now here's where I'll get into the details of everything I've tried (with no success on anything, obviously). Keep in mind I've not only tried these individual things, but practically every combination of them you can think of, as I've been actively trying for...maybe 9 months?

1. I've tried turning security off on the router.
2. I've tried opening necessary ports on router just for the Wii U.
3. I've tried removing external SSD and any other nearby electronics (it's usually next to all my other consoles which are Wi-Fi enabled too).
4. I've tried clearing all cache on my router.
5. I've tried resetting my router to factory settings.
6. I've tried manually connecting my console to the Wi-Fi by putting in the network information, including quite a few 'suggested' DNS servers I've found online.
7. I've tried setting a static IP via my router/console.
8. I've tried connecting to a different router (the Google WiFi router, launch model).
9. I've tried plugging in a network adapter (both a new ugreen adapter that SAYS it doesn't work on Wii U, but reviewers say it does AND the I tried the official Nintendo adapter). Bear in mind I tested both adapters on my Switch AND my laptop, and they worked fine. But no matter which USB port I plugged them into, it wouldn't be detected. And I know the ports I tested work (minus the dead one) because my external works on them.

I think that about sums it up. If I think of anything else I've tried I'll add it to the list. I really appreciate any and all help you guys can provide. I'm VERY fearful of formatting and losing everything I own, especially if it's an internal network adapter issue so that I lose everything for nothing. Thanks!
 

Latest posts

Latest threads

Top