Odd New 3DS XL Behavior after repair

zincmann

New Member
Karma
1
Playing
Wii U
So I acquired a new 3DS XL that was tossed out by gamestop in their dumpster, yes I own a bunch of these but wanted to be able to fix this one and save it from impending doom. I did not know if it worked because they damaged the casing and damaged it out.

Upon repair I ended up replacing top and bottom screens and speaker cable (original was probably still good) yes I could have bought a used one for what I spent but it was the thought I wanted to build one that was busted so to speak.

Anyhow now that its almost back together this is whats happening (even checked all cable connections multiple times)

  1. On bootup it turns on only when I plug it in with battery and dont need to use power switch - checked to make sure that was all working
  2. When menu screen loads up its going haywire like some buttons are depressed and just moving all over the screen
  3. Sound is there but both sound and 3d sliders do not work
  4. Will recognize a game and load it up and actually be able to play it normally with no issues, all buttons work
  5. Not able to use home button it does not seem to work but I know its wired in and double checked all contacts
  6. Not able to shut it off unless i use the software screen button touch to do so
  7. Checked Circle pad and that seems to be fine
  8. Checked all membranes under d pad, a,b,x,y, star and select all good.
I have tried the following so far to troubleshoot:

  1. Rechecked touch screen cables and made sure nothing was inside between digitizer and screen all clean there
  2. unplugged home button and powered up, same behavior
  3. unplugged back cover shoulder buttons, same behavior
  4. No water damage and no corrosion on board that I can see
  5. No cracks to board either that I can see
Could it be a bad speaker cable even though I bought one to replace the one that was in there?
Bad Camera unit?

Thanks any help would be greatly appreciated.
 

Latest posts

Latest threads

Top